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Microsoft PowerPoint 2016 
Basic Authoring and Testing Guide 

Document Formatting 

1. Is the file name descriptive, and is the file in the “*.pptx” 
format? 

How to test 

Instruction: Find the filename in File Explorer OR the title bar in MS PowerPoint. For example, 
“Presentation1” is non-descriptive, while “AccessibleElectronicDocuments.pptx.” is a descriptive 
filename. The file must be in the “*.pptx” format for accessibility testing to be possible. 

NOTE: If the file name extension is not displayed, open the documents folder in File Explorer, 
select the “View” tab and enable the option for “File name extensions” in the “Show/hide” group. 

Figure 1: “Save As” options window 

 

Test A: Is the file name descriptive and does it identify the document or its purpose? If not, the 
document fails this test. 

Test B: Is the file in “PowerPoint (*.pptx)” format? If not, the document fails this test. 

How to author for accessibility 

A descriptive file name identifying the document or its purpose helps everyone locate, open, and 
switch between documents. The document must be in a “*.pptx” format because these authoring 
and testing instructions will only work if the file is in the “*.pptx” file format. 

• Select “File tab>Save As.” 
• Save as type: “PowerPoint Presentation(*.pptx)”. 
• Save the document with a descriptive file name. 
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Text Formatting 

2. Does the reading order match the visual layout? 
How to test 

Instruction: Open the “Selection pane” (“Home tab> Drawing>Arrange>Selection Pane”). The 
first object (picture, textbox, table, etc.) on the slide will be listed last (at the bottom) of the 
Selection pane. Starting from the bottom and moving to the top, select each object to view the 
reading order on the slide. 

Test: Does the selection of each object match the visual reading order of the slide? If not, the 
document fails this test. 

Figure 2: Example of selected and subsequent objects matching the slide layout reading order 

 

How to author for accessibility 

Objects (such as text, pictures, and tables) in PowerPoint slides must be placed corresponding to 
the intended reading order to ensure assistive technology users can read the slide content in a 
logical manner. When adding objects to a slide, use the Selection Pane to arrange the layout to 
follow the intended reading order. 

• Manually move objects listed in the Selection Pane (by using drag or cut-and-paste) to 
match the intended reading order. 

3. Are lists formatted correctly? 
How to test 

Instruction: Place the cursor on a list item. Determine if one of the list formatting indicators 
(“Home tab>Paragraph”) is selected. 
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Figure 3: List formatting in Paragraph group highlighted 

 

Test: Is the list formatting in the Paragraph group highlighted? If not, the document fails this 
test. 

How to author for accessibility 

Lists help organize and structure content. Assistive technology users cannot infer meaning from 
lists created by only using tabs, a dash, or a number. Using built-in list features applies the 
formatting that assistive technology users need to easily identify and follow lists. 

Select “Home tab>Paragraph” and select the “Bullets” or “Numbering” option when using lists in 
the presentation. 

To use the built-in list features: 

• Select the list feature and then type a list item, OR 
• Type the list item and then select the list feature. 

4. Are columns of content formatted correctly? 
How to test 

NOTE: This test is not needed if content does not appear in columns. 

Instruction: Place the cursor on content that appears formatted in columns (similar to how a 
newspaper or magazine article). Select “Home tab>Paragraph >Add or Remove Columns” option 
and determine if columnar formatting is enabled. 
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Figure 4: Example of text on a slide formatted in two columns 

 

Test: Are the correct number of columns highlighted? If not, the document fails this test. 

How to author for accessibility 

Assistive technology users cannot interpret information in the intended reading order when tabs 
or spaces are used to separate content into columns. 

To create columns on a slide 

• Select “Home tab>Paragraph>Add or Remove Columns” option. 
• Select content to format. 
• Select “Columns.” 
• Choose the number of columns. 

5. Is text formatted for the intended language? 
How to test 

Instruction: If the document contains words or phrases in multiple languages, or a language 
other than the defined default language, place the cursor on that text. Go to “Review 
tab>Language>Set Proofing Language.” 
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 Figure 5: “Review>Language>Language” options window displaying Korean settings 

 

Test: Is the text formatted in the correct language? If not, the document fails this test. 

How to author for accessibility 

A document may contain sections written in different languages. All non-default language text 
must be formatted to reflect its corresponding language so assistive technology can detect the 
assigned language and use the correct pronunciation. 

To set a different language, you: 

• Select text written in a different language. 
• Select “Review tab>Language> Set Proofing Language.” 
• Select the appropriate language from the list. 

6. Are link names descriptive? 
How to test 

Test: Do links in the presentation have meaningful names that describe their destination, 
function, and/or purpose OR are these determinable within context? If not, the document fails 
this test. 

Uniquely Named Link:  
www.section508.gov 

Link Determinable within context:  
Get My Section 508 Questions Answered 

https://section508.gov/content/help-and-faq
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An unclear link name with no context:  
click here 

How to author for accessibility 

Assistive technology users rely on meaningful names to determine the destination, function, or 
purpose of links. For example, multiple “click here” links may hinder assistive technology users 
because the name for each link is the same, while the destinations may be different. 

Naming and creating links: 

• To edit the name of a link, place the cursor on the link and edit the text.  

Note: deleting the last character in the link name will remove the link. 

• To create a hyperlink, select or type the hyperlink text and either “right click” and select 
“Hyperlink” or use “Ctrl+K” to open the “Insert Hyperlink” configuration window. 
Specify/verify the “Text to display” and the “Address” for the link and its destination, and 
select “OK.” 

Figure 6: “Insert Hyperlink” configuration window 

 

https://www.opm.gov/
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Object Formatting 

7. Is vital information in the background (i.e. Slide Master) 
included in the reading order? 

How to test 

Instruction: Search for vital information in headers, footers, and watermarks (e.g., Respond by 
X date, CONFIDENTIAL, or Do Not Distribute). Go to “Home tab>Drawing >Arrange>Selection 
Pane.” 

Figure 7: Example of vital information listed in the “Selection” pane 

 

Test: Is the Placeholder containing the vital information listed in the Selection pane? If not, the 
document fails this test. 

How to author for accessibility 

Vital information can be included in a separate text box on the Slide Master (background), or in 
the Header/Footer of the slide. Headers and Footers have to be enabled. 

To enable Headers and Footers in the presentation: 

• Select “Insert tab>Text>Header & Footer.” 
• Check the “Header” or “Footer” option. 
• Type in vital information, and 
• Select “Apply.” 
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8. Are data tables created using built-in features? 
How to test 

Instruction 1: Select a table and verify that the Ribbon displays the “Picture Tools” tab instead 
of the “Table Tools” tab. If the “Picture Tools” tab shows in the Ribbon, then the table is not 
editable, since it is a picture of a table. 

Figure 8: Image of data table displaying “Picture Tools” tab when selected 

 

Test A: Is the document free of pictures of tables? If not, the document fails this test. 

Instruction 2: Place the cursor on a table, and use the “Tab” key to move between table cells. 
Make sure cells do not span more than one column or row, which would indicate merged or split 
cells. 

Figure 15: Complex table with merged and split cells 

  

Test B: Are tables free of merged or split cells? If not, the document fails this test. 



 

Microsoft PowerPoint 2016 Basic Authoring and Testing Guide  Page | 9 

How to author for accessibility 

NOTE: To understand the association between table cells and their respective headers, assistive 
technology users need to be able to identify column and row headers in data tables. Documents 
with complex data tables (data tables with more than one header row, one or more header 
column, and/or merged or split cells), must be converted to an accessible format (i.e. a PDF 
document remediated for accessibility). Complex data tables cannot be made accessible in MS 
PowerPoint. 

To create a non-complex accessible data table: 

• Select “Insert tab>Table>Insert Table.”  
• Select the number of columns and rows. 
• Do not merge or split cells. 

Figure 9: “Insert Table” option with a 5 column by 3 rows Table selection 

 

9. Do images and other objects have alternative text? 
How to test 

Instruction 1: Select an image or object “right click (or Shift+F10)>Format Picture (Note: 
could say Format Object, Format Shape, etc.)>Layout & Properties icon>Alt Text,” and read the 
“Description” field. Also, search for a description of the image or object in nearby text. 
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Figure 10: Format Picture – Alt Text options  

 

Test A: Does the image/object/shape have descriptive text as alt text, or is it described in the 
surrounding text? If not, the document fails this test. 

Instruction 2: Select an image or object that is just for decoration, right-click (or 
Shift+F10)>Format Picture (Note: could say Format Object, Format Shape, etc.)>Size & 
Properties icon>Alt Text, and read the “Description” field. 

Figure 11: Decorative Content – alternative text description using “quote space space quote.” 
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Test B: Does the “Description” field of decorative images or objects contain blank spaces 
between quotes? If not, the document fails this test. 

How to author for accessibility 

Assistive technology users cannot infer meaning from images and other objects such as pictures, 
images of text, images of tables, shapes, icons with hyperlinks, etc. A brief description in the 
form of alternative text (Alt Text), a caption or information in the surrounding text relating the 
purpose or meaning of the image/object provides assistive technology users comparable access 
to the content.  

To enter alternative text:  

• Select the image, object, or shape.  
• “Right click (or Shift+F10)” and select “Format Picture (could say Format Object, Format 

Shape, etc.)>Alt Text.” 
• In the “Description” field, enter information that states the purpose (in as few words as 

possible while remaining clear) for a meaningful image or object, OR enter one or two 
spaces between quotes for decorative objects.  
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Color Formatting 

10. Are colors and other visual characteristics that convey 
information also described in text? 

How to test 

Using only color or other visual characteristics, such as size, shape, or location, to convey 
meaning will not provide comparable access to people who are blind, have low vision, or 
are colorblind. 

Instruction: Find where color and/or other visual characteristics are used to convey meaning 
such as green, large yellow square, top left, etc. 

Test: Is there text that conveys the meaning of the color or other visual characteristics? If not, 
the document fails this test. 

How to author for accessibility 

The following layout tables describe the progress for three projects using colors to symbolize the 
current project status. Adding text in addition to the color provides comparable information to 
assistive technology users and people who are colorblind. 

Use text descriptions to duplicate the meaning of a color or other visual characteristics, such as 
size, shape, and location. 

Table 1: Examples of a project status table using only color and color with text description 

Project Status 

Project A  

Project B  
Project C  

 

Project Status 

Project A On Time 

Project B At Risk 
Project C Late 

 

11. Is the contrast ratio between text and background sufficient? 
NOTE: This test is not necessary, if the document text is black on white background (or close to 
it). This test requires the Colour Contrast Analyser (an external application). 

https://www.paciellogroup.com/resources/contrastanalyser
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How to test 

Instruction: Execute the Colour Contrast Analyser. Drag the “Foreground eyedropper” icon over 
a sample of the text or image of text. Drag the “Background eyedropper” icon over a sample of 
the background color. 

Figure 12: Examples of pass and fail results with the Colour Contrast Analyser 

 

Test: Have you formatted with the correct color contrast ratio? If not, the document fails this 
test. 
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How to author for accessibility 

People who are colorblind or have low vision will have comparable access if there is sufficient 
contrast between the text and the background. The contrast standards are: 

Table 2: Contrast ratios for types and sizes of text 

Type or Size of Text Contrast Ratio 

Standard text (12 pt regular) 4.5:1 

Large Text (14 pt bold or 18 pt regular) 3:1 

Incidental text, text overlaid on images, and logotypes Excluded from requirement 

 

Create content with text or images of text that use color or shading with sufficient color contrast. 
If the contrast ratio fails, then adjust the foreground or background until it passes. 

Table 3: Examples of good and insufficient color contrast 

Good Color Contrast Insufficient Color Contrast 

White text on black 
background 

Dark gray text on black 
background 

Dark green text on yellow 
background 

Orange text on yellow 
background 

Light blue text on blue 
background Red text on blue background 

white text on red background Dark green text on red 
background 
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Miscellaneous 

12. Are there corresponding descriptions of embedded files and are 
they accurate? 

How to test 

NOTE: This test is not necessary, if the document does not contain audio, video, or multimedia 
files. 

Instruction: Activate the audio-only, video-only, or multimedia file. 

Test A: Is there an accurate and complete text transcript for multimedia files, text description 
for audio files, and synchronized caption and/or audio description for video files? If not, the 
document fails this test. 

How to author for accessibility 

MS PowerPoint presentations with embedded audio-only, video-only, or multimedia file that 
contain meaningful information must have additional documentation so that individuals with 
disabilities have comparable access to the information. 

• Audio only files 
• Should have an accurate and complete transcript 
• Video Only files 
• Should have an accurate and complete text description 
• Synchronized media (audio and video) files 
• Should have accurate and complete synchronized captions and audio descriptions 

13. Did you exclude flashing objects? 
How to test 

Test: Is the document free of all flashing objects? If not, the document fails this test. 

How to author for accessibility 

Create content without using flashing objects. Flashing objects can cause seizures and should 
never be used. 
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